Skip to main content
VulnerabilityPublished

CVE-2026-111966: User Profile Builder (WordPress plugin) · Cross-site Scripting

Affects User Profile Builder (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.8 Medium : upgrade to 4.0.5 when convenient.

Data as of 29 Oct 2026, 19:15 UTC

CVSS 3.1 base score
6.8Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.16.8
EPSS
0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CISA SSVC
Exploitation
No evidence of active exploitation and no public proof of concept
Automatable
Attackers cannot reliably automate steps 1–4 of the kill chain
Technical impact
Total control over the software or total information disclosure

CISA SSVC assessment, 2026-10-23.

Patch
Available – fixed in 4.0.5
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade User Profile Builder (WordPress plugin) to 4.0.5.

Affected software

ProductAffectedFixed in
User Profile BuilderAffected
  • <4.0.5
Fixed in
  • 4.0.5

AI-suggested

Upgrade the User Profile Builder plugin to version 4.0.5 or later, where this vulnerability has been fixed. No additional mitigation steps are required once the plugin is updated.

Description

A stored cross-site scripting (XSS) vulnerability exists in the User Profile Builder WordPress plugin versions before 4.0.5. The flaw arises because one shortcode attribute is not properly sanitized or escaped before being output in a redirect message. This allows users with contributor-level roles to inject malicious scripts that execute in the context of higher-privileged users who submit the affected form.

References

Community reviews

Loading reviews…