CVE-2026-111974: GiveWP (WordPress plugin) · Improper Input Validation
Affects GiveWP (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 5.3 Medium : upgrade to 4.19.0.1 when convenient.
Data as of 26 Oct 2026, 08:45 UTC
- Patch
- Available – fixed in 4.19.0.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 26 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade GiveWP (WordPress plugin) to 4.19.0.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| GiveWP | Affected
| Fixed in
|
AI-suggested
Upgrade the GiveWP plugin to version 4.19.0.1 or later, where this input validation issue has been fixed. No other mitigation is required as the fix is available and official.
Description
CVE-2026-111974 is a vulnerability in the GiveWP WordPress plugin versions before 4.19.0.1. It allows unauthenticated users to bypass the configured minimum or fixed donation amounts by exploiting improper input validation related to currency handling. The plugin does not restrict donations to the accepted currency and compares amount limits as bare numbers, enabling donations below the intended minimum.