CVE-2026-112072: jopenlibs vault-java-driver · Uncontrolled Recursion
Affects jopenlibs vault-java-driverSource CVE Database V5
Not known to be exploited · CVSS 6.5 Medium : upgrade to 7.0.0 when convenient.
Data as of 5 Nov 2026, 09:23 UTC
Thin evidence
One scorer or none| CNA (Echo) | CVSS 3.1 | 6.5 |
|---|
- Patch
- Available – fixed in 7.0.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 5 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade vault-java-driver and io.github.jopenlibs/vault-java-driver to 7.0.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| vault-java-driverio.github.jopenlibs:vault-java-driver | Affected
| Fixed in
|
Mavenio.github.jopenlibs/vault-java-driverpkg:maven/io.github.jopenlibs/vault-java-driverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade vault-java-driver to version 7.0.0 or later, where this issue is fixed. Additionally, using Vault server version 1.20 or later mitigates the issue by rejecting deeply nested values beyond 298 levels. No other specific mitigations are indicated.
Description
CVE-2026-112072 is a vulnerability in the vault-java-driver library used to interact with HashiCorp Vault. The issue arises from a minimal-json parser with no limit on nesting depth, allowing deeply nested JSON values to cause a StackOverflowError. This error escapes typical exception handling and crashes the reading thread. The vulnerability affects versions 5.2.0 through 6.2.3 and requires Vault versions 1.19.x or earlier, as Vault 1.20 and later reject deeply nested values beyond 298 levels. The issue is fixed in vault-java-driver version 7.0.0.