CVE-2026-112347: Kirki (WordPress plugin) · Missing Authorization
Affects Kirki (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 7.2 High : upgrade to 6.4.1 soon.
Data as of 30 Oct 2026, 14:33 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 7.2 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 7.6 |
- CISA SSVC
- Exploitation
- No evidence of active exploitation and no public proof of concept
- Automatable
- Attackers cannot reliably automate steps 1–4 of the kill chain
- Technical impact
- Limited control over the software or limited information exposure
CISA SSVC assessment, 2026-10-30.
- Patch
- Available – fixed in 6.4.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:H/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 30 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Kirki (WordPress plugin) to 6.4.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| ThemeumKirki | Affected
| Fixed in
|
AI-suggested
Upgrade the Kirki plugin to version 6.4.1 or later, where this vulnerability is fixed. The fixed version implements proper per-object WordPress capability checks to enforce authorization correctly. No additional mitigation is required once the plugin is updated.
Description
Kirki plugin for WordPress versions before 6.4.1 has a broken object-level access control vulnerability in its REST API. This flaw allows users with the Editor role, who have Kirki edit access, to modify the title, slug, and publication status of any non-trashed post, including custom post types and WooCommerce products they do not own. The vulnerability arises because the plugin relies only on a coarse role-based check without verifying per-object WordPress capabilities. This can lead to unauthorized exposure or removal of content.