CVE-2026-112816: Canonical LXD · Improper Certificate Validation
Affects Canonical LXDSource CVE Database V5
Not known to be exploited · CVSS 10.0 Critical · fixed in 6.10.1 : patch Canonical LXD as a priority.
Data as of 30 Oct 2026, 17:48 UTC
Thin evidence
One scorer or none| CNA (canonical) | CVSS 4.0 | 10.0 |
|---|
- Patch
- Available – fixed in 6.10.1, 5.21.9, 5.0.11 +1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:HExploitation evidence
Disclosed: evidence found.
CVE published 30 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade LXD and lxd to 6.10.1, 5.21.9, 5.0.11 or 4.0.15.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| LXDlxd | Affected
| Fixed in
|
| LXDlxd | Affected
| Fixed in
|
| LXDlxd | Affected
| Fixed in
|
| LXDlxd | Affected
| Fixed in
|
GitHublxdpkg:github/lxdOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Canonical LXD to one of the fixed versions: 4.0.15, 5.0.11, 5.21.9, or 6.10.1. Applying these official fixes fully mitigates the vulnerability. No other mitigation is indicated or required.
Description
Improper certificate validation in the HTTPS listener in Canonical LXD 4.0.14, 5.0.10, 5.21.8, 6.9 before 4.0.15, 5.0.11, 5.21.9, 6.10.1 allows an unauthenticated attacker to authenticate as any trusted client and gain full access to the cluster and managed virtual machines via a crafted certificate chain.
References
- github.com/canonical/lxd/security/advisories/GHSA-99jp-jwmc-65p4 (opens in a new tab)
- discourse.ubuntu.com/t/security-advisory-critical-vulnerability-found-in-canonical-lxd-and-microcloud/90557 (opens in a new tab)
- discourse.ubuntu.com/t/lxd-6-10-1-lts-has-been-released/90024 (opens in a new tab)
- discourse.ubuntu.com/t/lxd-5-21-9-lts-has-been-released/90565/1 (opens in a new tab)
- discourse.ubuntu.com/t/lxd-5-0-11-lts-has-been-released/90570/1 (opens in a new tab)
- discourse.ubuntu.com/t/lxd-4-0-15-lts-has-been-released/90571 (opens in a new tab)