CVE-2026-113715: pypa virtualenv · CRLF Injection
Affects pypa virtualenvSource CVE Database V5
Not known to be exploited · CVSS 2.0 Low : upgrade to 21.14.9 when convenient.
Data as of 29 Oct 2026, 19:15 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 4.0 | 2.0 |
|---|
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 21.14.9
CVSS:4.0/AV:L/AC:H/AT:P/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 20 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade pypa virtualenv to 21.14.9.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| pypavirtualenv | Affected
| Fixed in
|
PyPIvirtualenvpkg:pypi/virtualenvOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade virtualenv to version 21.14.9 or later, where this vulnerability is fixed. No other mitigation is required as the issue is resolved in the official patch.
Description
CVE-2026-113715 is a low-severity CRLF injection vulnerability in pypa virtualenv versions prior to 21.14.9. It allows an untrusted caller who can influence the destination pathname to inject line-boundary characters into the pyvenv.cfg file, altering configuration keys such as 'home' and 'include-system-site-packages'. This can weaken environment isolation or change the interpreter's standard library loading path. The issue is fixed in version 21.14.9.
References
- github.com/pypa/virtualenv/security/advisories/GHSA-qmx5-4p3x-wvqf (opens in a new tab)
- github.com/pypa/virtualenv/pull/3426 (opens in a new tab)
- github.com/pypa/virtualenv/commit/b0008a58885ded9227faf8f910c6c402712c750a (opens in a new tab)
- github.com/pypa/virtualenv/releases/tag/21.14.9 (opens in a new tab)