CVE-2026-113788: uselagoon lagoon · OS Command Injection
Affects uselagoon lagoonSource CVE Database V5
Not known to be exploited · CVSS 9.4 Critical : upgrade to 2.33.2 as a priority.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.33.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:HExploitation evidence
Disclosed: evidence found.
CVE published 21 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade lagoon and uselagoon/lagoon to 2.33.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| uselagoonlagoon | Affected
| Fixed in
|
GitHubuselagoon/lagoonpkg:github/uselagoon/lagoonOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fixed version is available: Lagoon v2.33.2 resolves this vulnerability. Users should upgrade to this version or later. As a temporary workaround, the ssh service in Lagoon core can be disabled to prevent exploitation. The ssh-portal service and other components are not affected and can continue to be used safely. Monitoring container logs of the ssh service for the message 'too many arguments' may help detect exploitation attempts.
Description
Lagoon is an application delivery platform for Kubernetes. Versions prior to 2.33.1 have a vulnerability in the `ssh` service in Lagoon core that would allow an attacker to execute arbitrary code which could lead to, among other things, elevated administrative permissions. It is mitigated by the fact that an attacker must have a Lagoon user account. Exploitation may be detected by checking the container logs of the `ssh` service for: `too many arguments`. The vulnerability was fixed in Lagoon v2.33.2, which is included in the `lagoon/lagoon-core` helm chart v1.62.2. As a workaround, the `ssh` service in Lagoon core can be disabled. The `ssh-portal` service and components are not effected and can continue to be used.