Skip to main content
VulnerabilityPublished

CVE-2026-11393: AWS AgentCore CLI · Code Injection

Affects AWS AgentCore CLISource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.0 Critical : upgrade to 0.14.2 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
9.0Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 27% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.14.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade @aws/agentcore to 0.14.2.

Affected software

ProductAffectedFixed in
AWSAgentCore CLIAffected
  • >=0.4.0 <=0.14.1
  • >=0.3.0-preview.7.0 <=1.0.0-preview.8
Fixed in–
npm@aws/agentcorepkg:npm/@aws/agentcoreOther threatsAffected
  • <0.14.2
Fixed in
  • 0.14.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available. Users should upgrade AWS AgentCore CLI to version 0.14.2 to remediate this vulnerability. Since this is a cloud service, AWS manages remediation for the cloud-hosted components, but local CLI upgrades are required to fully mitigate the risk.

Description

CVE-2026-11393 is a critical code injection vulnerability in AWS AgentCore CLI versions before 0.14.2. It involves improper neutralization of triple-quote characters during Python code generation, allowing an authenticated remote attacker to execute arbitrary code under the imported agent's IAM execution role and on the local environment of another user in the same AWS account. The vulnerability is remediated by upgrading to version 0.14.2.

References

Community reviews

Loading reviews…