Skip to main content
VulnerabilityPublished

CVE-2026-114131: nuxt · Interpretation Conflict

Affects nuxtSource CVE Database V5

0

Not known to be exploited · CVSS 6.5 Medium : upgrade to 4.4.4 or 3.21.4 when convenient.

Data as of 26 Oct 2026, 11:07 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 29% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.4.4, 3.21.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 24 Oct 2026.

What to do

Upgrade nuxt to 4.4.4 or 3.21.4.

Affected software

ProductAffectedFixed in
nuxtnuxtAffected
  • >=4.0.0 <4.4.4
Fixed in
  • 4.4.4
nuxtnuxtAffected
  • >=3.11.0 <3.21.4
Fixed in
  • 3.21.4

Description

Nuxt is an open-source web development framework for Vue.js. From 3.11.0 until 3.21.4 and 4.4.4, Nuxt compares route-rule keys with the raw request path while route resolution decodes dynamic and catch-all parameters, allowing a percent-encoded segment to resolve to a protected page without matching the routeRules entry intended for that path. As a result, appMiddleware can be skipped during server rendering and an unauthenticated requester can receive the gated page and its SSR data. The same mismatch affects app-manifest rules including redirect, appLayout, ssr, prerender, and payload flags derived from cache, isr, and swr. This vulnerability is fixed in 4.4.4 and 3.21.4.

References

Community reviews

Loading reviews…