CVE-2026-114133: nuxt · Cross-site Scripting
Affects nuxtSource CVE Database V5
Not known to be exploited · CVSS 5.4 Medium : upgrade to 4.6.2 when convenient.
Data as of 26 Oct 2026, 19:32 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.6.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 21 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade nuxt to 4.6.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| nuxtnuxt | Affected
| Fixed in
|
AI-suggested
Upgrade Nuxt to version 4.6.2 or later, where this vulnerability is fixed. No other mitigation actions are indicated or required according to the vendor advisory.
Description
A stored cross-site scripting (XSS) vulnerability exists in Nuxt versions from 3.13.0 up to but not including 4.6.2. The issue arises because the server-island renderer improperly serializes raw useHeadSafe input without preserving its safe-input marker, allowing attacker-controlled data to be inserted into the page head as ordinary entries. This can lead to execution of malicious scripts if untrusted input is passed to useHeadSafe in server-side components or pages. The vulnerability is fixed in Nuxt version 4.6.2.