Skip to main content
VulnerabilityPublished

CVE-2026-114348: webpack-dev-server · Generation of Error Message Containing Sensitive Information

Affects webpack-dev-serverSource CVE Database V5

0

Not known to be exploited · CVSS 5.3 Medium : upgrade to 6.1.0 or 5.2.7 when convenient.

Data as of 26 Oct 2026, 19:04 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CISA SSVC
Exploitation
No evidence of active exploitation and no public proof of concept
Automatable
Attackers can reliably automate steps 1–4 of the kill chain
Technical impact
Limited control over the software or limited information exposure

CISA SSVC assessment, 2026-10-22.

Patch
Available – fixed in 6.1.0, 5.2.7
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade webpack-dev-server to 6.1.0 or 5.2.7.

Affected software

ProductAffectedFixed in
webpack-dev-serverwebpack-dev-serverAffected
  • >=6.0.0 <6.1.0
Fixed in
  • 6.1.0
webpack-dev-serverwebpack-dev-serverAffected
  • >=5.1.0 <5.2.7
Fixed in
  • 5.2.7
npmwebpack-dev-serverpkg:npm/webpack-dev-serverOther threatsAffected
  • >=5.1.0 <5.2.7
  • >=6.0.0 <6.1.0
Fixed in
  • 5.2.7
  • 6.1.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade webpack-dev-server to version 5.2.7 or later, or 6.1.0 or later, where this issue is fixed. No other mitigation is required as the vulnerability is resolved in these versions.

Description

A vulnerability in webpack-dev-server versions 5.1.0 up to but not including 5.2.7, and 6.0.0 up to but not including 6.1.0, allows unauthenticated attackers to cause the server to disclose sensitive information via error messages. This occurs because the open-editor endpoint improperly validates the Host header, leading to an exception that reveals absolute filesystem paths, module locations, and source line numbers in HTTP 500 responses. The server continues running without denial of service. The issue is fixed in versions 5.2.7 and 6.1.0.

References

Community reviews

Loading reviews…