Skip to main content
VulnerabilityPublished Updated

CVE-2026-11441: theonedev onedev · Improper Authorization

Affects theonedev onedevSource CVE Database V5

0

Not known to be exploited · CVSS 5.3 Medium : upgrade to 15.0.6 when convenient.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 15.0.6
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade theonedev/onedev to 15.0.6.

Affected software

ProductAffectedFixed in
theonedevonedevAffected
  • 15.0.0 – 15.0.5
6 affected builds
Fixed in–
GitHubtheonedev/onedevpkg:github/theonedev/onedevOther threatsAffected
  • <15.0.6
Fixed in
  • 15.0.6

CPE configurations (1)

  • cpe:2.3:a:theonedev:onedev:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade theonedev onedev to version 15.0.6 or later, which addresses this improper authorization vulnerability. No other mitigations are specifically indicated.

Description

A vulnerability was identified in theonedev onedev up to 15.0.5. This vulnerability affects the function canAccessIssue of the file /issues/ of the component Pull Request Handler. Such manipulation of the argument issue leads to improper authorization. It is possible to launch the attack remotely. Upgrading to version 15.0.6 is able to resolve this issue. It is advisable to upgrade the affected component.

References

Community reviews

Loading reviews…