CVE-2026-114422: Enable Media Replace (WordPress plugin) · Deserialization of Untrusted Data
Affects Enable Media Replace (WordPress plugin)Source CVE Database V5
Mentioned vulnerabilities
Not known to be exploited : upgrade to 4.2.3 soon.
Data as of 30 Oct 2026, 06:29 UTC
Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD
Thin evidence
One scorer or none- Patch
- Available – fixed in 4.2.3
Exploitation evidence
Disclosed: evidence found.
CVE published 30 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Enable Media Replace (WordPress plugin) to 4.2.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Enable Media Replace | Affected
| Fixed in
|
AI-suggested
Upgrade the Enable Media Replace plugin to version 4.2.3 or later, where this vulnerability has been fixed. No other mitigation is required as the fix addresses the root cause by restricting allowed classes during deserialization.
Description
The Enable Media Replace WordPress plugin versions 4.1.4 through 4.2.2 contain a deserialization vulnerability that allows unauthenticated users to inject PHP objects during media replacement operations. This can lead to PHP Object Injection and local file inclusion, potentially escalating to remote code execution if attacker-controlled PHP or HTML files exist on the server. The issue is a regression of a previously fixed vulnerability (CVE-2023-4643) and was corrected in version 4.2.3.