Skip to main content
VulnerabilityPublished

CVE-2026-114442: Apache HertzBeat · XPath Injection

Affects Apache HertzBeatSource CVE Database V5

0
Compare

Mentioned vulnerabilities

Not known to be exploited · fixed in 1.9.1 : update Apache HertzBeat when convenient.

Data as of 3 Nov 2026, 11:11 UTC

Severity
Medium

Rated Medium by Threat Radar's AI analysis · CVSS not yet scored by NVD

Thin evidence

One scorer or none
Patch
Available – fixed in 1.9.1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Software FoundationApache HertzBeatAffected
  • 1.7.1 – 1.9.0
5 affected builds
Fixed in–
GitHubapache/hertzbeatpkg:github/apache/hertzbeatOther threatsAffected
  • 1.7.1 – 1.9.0
5 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Apache HertzBeat to version 1.9.1 or later, where the vulnerability has been fixed. No other mitigation or workaround is indicated.

Description

Apache HertzBeat versions 1.7.1 through 1.9.0 contain an XPath injection vulnerability due to incomplete validation of XPath expressions in the HTTP collector XML parsing path. Authenticated users with permission to create monitor templates can supply crafted XPath expressions that are evaluated without proper validation, potentially causing excessive CPU consumption and impairing collector availability. This issue is a follow-up to a previous incomplete fix (CVE-2026-24343). The vulnerability is fixed in version 1.9.1, and users are advised to upgrade.

References

Community reviews

Loading reviews…