CVE-2026-11447: GL.iNet GL-MT3000 · Command Injection
Affects GL.iNet GL-MT3000Source CVE Database V5
Public exploit available · CVSS 5.3 Medium : upgrade to 4.7 as a priority.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 1.0% chance of exploitation in 30 days – higher than 64% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.7
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 7 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade gl.inet/GL-MT3000 to 4.7.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| GL.iNetGL-MT3000 | Affected
| Fixed in– |
GitHubgl.inet/GL-MT3000pkg:github/gl.inet/GL-MT3000Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade affected GL.iNet GL-MT3000 devices to firmware version 4.7 or later, where the vendor has implemented global protections against command injection. This is the recommended and official fix to address the vulnerability.
Description
A security flaw has been discovered in GL.iNet GL-MT3000 up to 4.4.5. Impacted is the function iwinfo_backend of the file iwinfo.so of the component MTK Backend. The manipulation of the argument device results in command injection. The attack can be executed remotely. The exploit has been released to the public and may be used for attacks. Upgrading to version 4.7 is recommended to address this issue. Upgrading the affected component is recommended. The vendor confirms: "Starting from version 4.7, SDK has added global protection to intercept malicious injection".