Skip to main content
VulnerabilityPublished

CVE-2026-114622: baserproject basercms · Path Traversal

Affects baserproject basercmsSource CVE Database V5

0

Mentioned vulnerabilities

Not known to be exploited · CVSS 7.2 High : upgrade to 5.4.2 or 5.3.2 soon.

Data as of 26 Oct 2026, 13:47 UTC

CVSS 3.1 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.4.2, 5.3.2
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade basercms and baserproject/basercms to 5.4.2 or 5.3.2.

Affected software

ProductAffectedFixed in
baserprojectbasercmsAffected
  • >=5.4.0 <5.4.2
Fixed in
  • 5.4.2
baserprojectbasercmsAffected
  • >=5.2.3 <5.3.2
Fixed in
  • 5.3.2
GitHubbaserproject/basercmspkg:github/baserproject/basercmsOther threatsAffected
  • >=5.2.3 <5.3.2
  • >=5.4.0 <5.4.2
Fixed in
  • 5.3.2
  • 5.4.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability has been officially fixed in baserCMS versions 5.3.2 and 5.4.2. Users should upgrade to these versions or later to remediate the issue. No additional mitigation is required if these versions are deployed. Exploitation requires the optional BcThemeFile plugin and an administrator session, so disabling the plugin or restricting administrator access may reduce risk temporarily but is not a substitute for patching.

Description

baserCMS versions 5.2.3 before 5.3.2 and 5.4.0 before 5.4.2 contain a path traversal vulnerability in the optional BcThemeFile plugin's Admin API. The vulnerability arises because encoded path traversal sequences are decoded after validation, allowing an authenticated administrator to write PHP files outside the intended theme directory, such as into the webroot, and execute them. Exploitation requires an administrator session, the non-default plugin enabled, and a same-origin Origin header. The issue has been patched in versions 5.3.2 and 5.4.2.

References

Community reviews

Loading reviews…