Skip to main content
VulnerabilityPublished

CVE-2026-11487: Neovim · Command Injection

Affects NeovimSource CVE Database V5

0
Compare

Public exploit available · CVSS 4.8 Medium : upgrade to 0.12.3 as a priority.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 4.0 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.9% chance of exploitation in 30 days – higher than 60% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.12.3
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade neovim/neovim to 0.12.3.

Affected software

ProductAffectedFixed in
NeovimAffected
  • =0.12.0
  • =0.12.1
  • =0.12.2
Fixed in–
GitHubneovim/neovimpkg:github/neovim/neovimOther threatsAffected
  • <0.12.3
Fixed in
  • 0.12.3

CPE configurations (1)

  • cpe:2.3:a:neovim:neovim:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch identified by commit f83e0dcaf8cf18de94828341b0a1a61a86c75baf has been created to fix this vulnerability. Users of Neovim versions 0.12.0, 0.12.1, and 0.12.2 should apply this patch or upgrade to a fixed version once available. Patch status is not explicitly confirmed in the provided data; therefore, users should consult the official Neovim repository or vendor advisory for the latest remediation guidance.

Description

Neovim versions 0.12.0 through 0.12.2 contain a command injection vulnerability in the M.read function within runtime/lua/vim/secure.lua. This flaw allows an attacker with local access to manipulate the path argument to execute arbitrary commands. A patch identified by commit f83e0dcaf8cf18de94828341b0a1a61a86c75baf has been created to address this issue. The vulnerability has a medium severity rating with a CVSS score of 4.8.

References

Community reviews

Loading reviews…