Skip to main content
VulnerabilityPublished

CVE-2026-11500: Weaviate · Authorization Bypass

Affects WeaviateSource CVE Database V5

0
Compare

Public exploit available · CVSS 2.3 Low · fixed in 1.38.0 : patch Weaviate as a priority.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
2.3Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 27% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.38.0
CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
WeaviateAffected
  • 1.37.0 – 1.37.7
8 affected builds
Fixed in–
GitHubweaviate/weaviatepkg:github/weaviate/weaviateOther threatsAffected
  • 1.37.0 – 1.37.7
8 affected builds
Fixed in–

CPE configurations (1)

  • cpe:2.3:a:weaviate:weaviate:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Weaviate to version 1.38.0-rc.0 or later, which contains the official fix for this vulnerability. Since the vulnerability is resolved in this version, no additional mitigation steps are required.

Description

CVE-2026-11500 is an authorization bypass vulnerability in Weaviate affecting versions 1.37.0 through 1.37.7. The issue exists in the Static API Key Handler component, specifically in the validateConfig function, where manipulation of the StaticApiKey argument can bypass authorization. The vulnerability can be exploited remotely but requires high attack complexity and is difficult to exploit. A fix is available in version 1.38.0-rc.0.

References

Community reviews

Loading reviews…