Skip to main content
VulnerabilityPublished

CVE-2026-115358: openbao · Sensitive Data in Logs

Affects openbaoSource CVE Database V5

0

Not known to be exploited · CVSS 2.0 Low : upgrade to 2.6.3 when convenient.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 4.0 base score
2.0Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.6.3, 2.7.1
CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade openbao to 2.6.3; openbao and github.com/openbao/openbao/sdk/v2 to 2.7.1 or 2.6.3.

Affected software

ProductAffectedFixed in
openbaoopenbaoAffected
  • <2.6.3
Fixed in
  • 2.6.3
openbaogithub.com/openbao/openbao/sdk/v2Affected
  • >=2.7.0 <2.7.1
Fixed in
  • 2.7.1
openbaogithub.com/openbao/openbao/sdk/v2Affected
  • <2.6.3
Fixed in
  • 2.6.3
Goopenbaopkg:golang/openbaoOther threatsAffected
  • <2.6.3
Fixed in
  • 2.6.3
Gogithub.com/openbao/openbao/sdk/v2pkg:golang/github.com/openbao/openbao/sdk/v2Other threatsAffected
  • <2.6.3
  • >=2.7.0 <2.7.1
Fixed in
  • 2.6.3
  • 2.7.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

OpenBao before 2.6.3 contains an information disclosure vulnerability that allows attackers to leak sensitive data into audit logs by sending malformed plugin parameters. Attackers can submit requests with malformed TypeKVPair or TypeHeader field values, causing error messages containing sensitive input to be recorded in audit logs.

References

Community reviews

Loading reviews…