Skip to main content
VulnerabilityPublished

CVE-2026-115415: AWS strands-agents-tools · Improper Neutralization of Input Used for LLM Prompting

Affects AWS strands-agents-toolsSource CVE Database V5

0

Not known to be exploited · CVSS 5.9 Medium : upgrade to 0.8.6 when convenient.

Data as of 28 Oct 2026, 19:57 UTC

CVSS 4.0 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.8.6
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade AWS strands-agents-tools to 0.8.6.

Affected software

ProductAffectedFixed in
amazonstrands-agents-toolsAffected
  • >=0.1.0 <0.8.6
Fixed in
  • 0.8.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade amazon strands-agents-tools to version 0.8.6 or later to remediate this vulnerability. Additionally, rotate any credentials that were present in the environment of agents that loaded the environment tool prior to the upgrade to prevent misuse of potentially exposed secrets.

Description

Improper neutralization of input used for LLM prompting in the environment tool in Strands Agents Tools before 0.8.6 might allow remote actors to obtain the agent host's environment variables in cleartext, including cloud credentials and API keys, via a crafted prompt that disables the tool's secret masking. To remediate this issue, users should upgrade to version 0.8.6 or later and rotate any credentials that were present in the environment of agents that loaded the environment tool.

Reports on CVE-2026-115415

References

Community reviews

Loading reviews…