Skip to main content
VulnerabilityPublished

CVE-2026-115513: OpenCATS · Cross-site Scripting

Affects OpenCATSSource CVE Database V5

0

Not known to be exploited · CVSS 6.3 Medium : upgrade to 0.12.0 when convenient.

Data as of 26 Oct 2026, 15:59 UTC

CVSS 4.0 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.12.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade OpenCATS to 0.12.0.

Affected software

ProductAffectedFixed in
opencatsOpenCATSAffected
  • >=0.10.0 <0.12.0
Fixed in
  • 0.12.0
GitHubOpenCATSpkg:github/OpenCATSOther threatsAffected
  • >=0.10.0 <0.12.0
Fixed in
  • 0.12.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade OpenCATS to version 0.12.0 or later, where this vulnerability is fixed. No other mitigation is required as the fix addresses the root cause by properly sanitizing and escaping user input in the affected fields.

Description

OpenCATS versions 0.10.0 up to but not including 0.12.0 contain a stored cross-site scripting (XSS) vulnerability. This flaw allows a low-privileged authenticated user to inject malicious HTML or JavaScript code into various name or title fields, which are then rendered unsanitized in the 'Recent' navigation panel on nearly every page. When other users, including administrators, view these records, the injected script executes in their sessions, potentially enabling session hijacking and privilege escalation. The vulnerability is fixed in OpenCATS version 0.12.0.

References

Community reviews

Loading reviews…