CVE-2026-115700: benoitc hackney · Interpretation Conflict
Affects benoitc hackneySource CVE Database V5
Mentioned vulnerabilities
Not known to be exploited · CVSS 6.9 Medium : upgrade to 4.9.0 when convenient.
Data as of 26 Oct 2026, 16:53 UTC
- Patch
- Available – fixed in 4.9.0, f19561a0b422376348c91537e51377ab7325f4ee
CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 26 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade hackney to 4.9.0; hackney to f19561a0b422376348c91537e51377ab7325f4ee.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| benoitchackney | Affected
| Fixed in
|
| hackneybenoitc/hackney | Affected
| Fixed in
|
Hexhackneypkg:hex/hackneyOther threats | Affected
| Fixed in
|
CPE configurations (1)
cpe:2.3:a:benoitc:hackney:*:*:*:*:*:*:*:*
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade hackney to version 4.9.0 or later, where this vulnerability is fixed. No additional mitigation is required once the upgrade is applied.
Description
CVE-2026-115700 is a Server Side Request Forgery (SSRF) vulnerability in the benoitc hackney library affecting versions from 4.0.1 up to but not including 4.9.0. The flaw arises from an interpretation conflict when handling percent-encoded bracketed IPv6 literals or IP literals with trailing dots, allowing bypass of allowlist checks and unintended connections to internal IP addresses. This issue was introduced as a fix attempt for a previous vulnerability (CVE-2026-47076) but still allows certain malformed IP literals to bypass validation. The vulnerability has a medium severity with a CVSS 4.0 score of 6.9 and is fixed in version 4.9.0.
References
- github.com/benoitc/hackney/releases/tag/4.9.0 (opens in a new tab)
- cna.erlef.org/cves/CVE-2026-115700.html (opens in a new tab)
- osv.dev/vulnerability/EEF-CVE-2026-115700 (opens in a new tab)
- github.com/benoitc/hackney/pull/987 (opens in a new tab)
- github.com/benoitc/hackney/commit/452620a92ec1da2e6b4862a049a2a4f04b42068f (opens in a new tab)
- github.com/benoitc/hackney/commit/f19561a0b422376348c91537e51377ab7325f4ee (opens in a new tab)