CVE-2026-115718: frappe builder · Missing Authorization
Affects frappe builderSource CVE Database V5
Not known to be exploited · CVSS 5.3 Medium : upgrade to 1.36.0 when convenient.
Data as of 26 Oct 2026, 17:30 UTC
- Patch
- Available – fixed in 1.36.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 26 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade frappe builder to 1.36.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| frappebuilder | Affected
| Fixed in
|
GitHubbuilderpkg:github/builderOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Frappe Builder to version 1.36.0 or later, where this missing authorization vulnerability is fixed. Until then, restrict access to authenticated users carefully or disable the improve_prompt endpoint if possible. No other vendor advisories indicate alternative mitigations.
Description
Frappe Builder versions 1.33.0 before1.36.0 contain a missing authorization vulnerability in the improve_prompt endpoint that allows any authenticated non-Guest session to invoke LLM completions without proper permission checks. Attackers can call the improve_prompt API to leverage the site owner's stored OpenRouter API key via resolve_api_key, consuming paid LLM credits and effectively turning the site into a free LLM proxy.