CVE-2026-115907: zip-rs zip2 · Uncontrolled Resource Consumption
Affects zip-rs zip2Source CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 9.0.0 soon.
Data as of 26 Oct 2026, 17:30 UTC
- Patch
- Available – fixed in 9.0.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 26 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade zip-rs zip2 to 9.0.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| zip-rszip2 | Affected
| Fixed in
|
AI-suggested
Upgrade to zip-rs zip2 version 9.0.0 or later, where this vulnerability is fixed. No other mitigation is required as the fix addresses the root cause.
Description
CVE-2026-115907 is a high-severity vulnerability in the zip-rs zip2 library for Rust, affecting versions from 5.1.0 up to but not including 9.0.0. The issue involves uncontrolled resource consumption due to unbounded preallocation of output capacity based on attacker-controlled ZIP64 uncompressed sizes before validating the compressed stream. This can cause a panic due to capacity overflow in certain decoder paths, potentially terminating an archive-processing service. The vulnerability is fixed in version 9.0.0.