Skip to main content
VulnerabilityPublished

CVE-2026-115910: python-social-auth social-core · Insufficient Verification of Data Authenticity

Affects python-social-auth social-coreSource CVE Database V5

0

Not known to be exploited · CVSS 6.8 Medium : upgrade to 6.2.0 when convenient.

Data as of 26 Oct 2026, 17:30 UTC

CVSS 3.1 base score
6.8Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 6.2.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade python-social-auth social-core to 6.2.0.

Affected software

ProductAffectedFixed in
python-social-authsocial-coreAffected
  • <6.2.0
Fixed in
  • 6.2.0
PyPIsocial-corepkg:pypi/social-coreOther threatsAffected
  • <6.2.0
Fixed in
  • 6.2.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade python-social-auth social-core to version 6.2.0 or later, where the nonce is properly bound to the browser session and OAuth state, preventing reuse attacks. If upgrading immediately is not possible, ensure that DEFAULT_USE_PKCE is enabled to mitigate the risk. No other vendor advisories indicate alternative mitigations or that the issue is already mitigated.

Description

CVE-2026-115910 is a vulnerability in python-social-auth's social-core component prior to version 6.2.0. It involves insufficient verification of the OpenID Connect nonce, which is stored globally rather than being bound to the initiating browser session and OAuth state. This flaw allows an attacker who obtains a victim's unused authorization code to reuse it with a valid state from a separate login, bypassing nonce validation and potentially logging in as the victim if PKCE is disabled. The issue is fixed in version 6.2.0.

References

Community reviews

Loading reviews…