CVE-2026-115918: vllm · Uncontrolled Resource Consumption
Affects vllmSource CVE Database V5
Not known to be exploited · CVSS 6.5 Medium : upgrade to 0.32.0 when convenient.
Data as of 26 Oct 2026, 17:44 UTC
- Patch
- Available – fixed in 0.32.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 26 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade vllm to 0.32.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| vllm-projectvllm | Affected
| Fixed in
|
AI-suggested
Upgrade vLLM to version 0.32.0 or later, where this vulnerability is fixed. No other mitigation or workaround is indicated by the vendor advisory.
Description
vLLM versions from 0.16.0 up to but not including 0.32.0 contain a vulnerability in the /v1/responses endpoint that allows an authenticated user to supply a malicious template in chat_template_kwargs[chat_template]. This bypasses the intended trust policy and can lead to uncontrolled CPU or memory consumption during Jinja template rendering. The issue is resolved in version 0.32.0.
References
- github.com/vllm-project/vllm/security/advisories/GHSA-x567-49g5-p4cf (opens in a new tab)
- github.com/vllm-project/vllm/pull/50300 (opens in a new tab)
- github.com/vllm-project/vllm/commit/cff08b461e086523cee8bba5bd3c66d302625134 (opens in a new tab)
- github.com/vllm-project/vllm/releases/tag/v0.32.0 (opens in a new tab)