CVE-2026-116142: ImageMagick · Out-of-bounds Read
Affects ImageMagickSource CVE Database V5
Not known to be exploited · CVSS 4.8 Medium : upgrade to 7.1.2-33 when convenient.
Data as of 26 Oct 2026, 14:18 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.1.2-33
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 25 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade ImageMagick to 7.1.2-33.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| ImageMagickImageMagick | Affected
| Fixed in
|
AI-suggested
Upgrade ImageMagick to version 7.1.2-33 or later, where this vulnerability is fixed. No other mitigations are indicated or necessary.
Description
ImageMagick versions before 7.1.2-33 contain a heap buffer over-read vulnerability that occurs when printing a minimum-bounding-box. An attacker can supply a specially crafted image to trigger this over-read, potentially causing application crashes or exposing adjacent heap memory.