CVE-2026-116148: ImageMagick · Cross-site Scripting
Affects ImageMagickSource CVE Database V5
Not known to be exploited · CVSS 4.8 Medium : upgrade to 7.1.2-33 when convenient.
Data as of 26 Oct 2026, 14:18 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 3% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.1.2-33, 6.9.13-58
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:L/VI:N/VA:N/SC:L/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 25 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade ImageMagick to 7.1.2-33; ImageMagick to 6.9.13-58.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| ImageMagickImageMagick | Affected
| Fixed in
|
| ImageMagickImageMagick | Affected
| Fixed in
|
AI-suggested
Fixed versions 6.9.13-58 and 7.1.2-33 are available and should be applied to remediate this vulnerability. Users should upgrade to these or later versions of ImageMagick. No additional mitigation steps are indicated by the vendor advisory.
Description
CVE-2026-116148 is a medium severity cross-site scripting (XSS) vulnerability in ImageMagick affecting versions before 6.9.13-58 and 7.x before 7.1.2-33. The flaw exists in the MVG encoder, which fails to properly neutralize user-supplied drawing options before embedding them into generated MVG files. This allows attackers who can supply drawing options to inject arbitrary MVG drawing commands.