Skip to main content
VulnerabilityPublished

CVE-2026-116151: ImageMagick · Memory Leak

Affects ImageMagickSource CVE Database V5

0

Not known to be exploited · CVSS 6.3 Medium : upgrade to 7.1.2-33 when convenient.

Data as of 26 Oct 2026, 15:59 UTC

CVSS 4.0 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.1.2-33, 6.9.13-58
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade ImageMagick to 7.1.2-33; ImageMagick to 6.9.13-58.

Affected software

ProductAffectedFixed in
ImageMagickImageMagickAffected
  • >=7.0.0-0 <7.1.2-33
Fixed in
  • 7.1.2-33
ImageMagickImageMagickAffected
  • <6.9.13-58
Fixed in
  • 6.9.13-58

AI-suggested

Apply the official fixes by upgrading ImageMagick to version 6.9.13-58 or later in the 6.x branch, or 7.1.2-33 or later in the 7.x branch. These versions contain the patch that resolves the memory leak in the JNG encoder. No other mitigation actions are indicated.

Description

CVE-2026-116151 is a memory leak vulnerability in ImageMagick's JNG encoder affecting versions before 6.9.13-58 and 7.x before 7.1.2-33. The flaw causes allocated memory to not be released when processing crafted images, potentially leading to resource exhaustion and a limited denial of service. The vulnerability has a medium severity rating and a CVSS 4.0 base score of 6.3. Fixed versions 6.9.13-58 and 7.1.2-33 are available.

References

Community reviews

Loading reviews…