CVE-2026-116154: ImageMagick · Memory Leak
Affects ImageMagickSource CVE Database V5
Not known to be exploited · CVSS 6.9 Medium : upgrade to 7.1.2-33 when convenient.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.1.2-33, 6.9.13-58
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 25 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade ImageMagick to 7.1.2-33; ImageMagick to 6.9.13-58.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| ImageMagickImageMagick | Affected
| Fixed in
|
| ImageMagickImageMagick | Affected
| Fixed in
|
AI-suggested
Update ImageMagick to version 6.9.13-58 or later in the 6.x branch, or 7.1.2-33 or later in the 7.x branch, where this memory leak has been fixed. No other mitigation is required as the issue is resolved in these releases.
Description
CVE-2026-116154 is a memory leak vulnerability in ImageMagick's XML parsing code affecting versions before 6.9.13-58 and 7.x before 7.1.2-33. The flaw occurs when parsing deeply nested XML data, where allocated memory is not released upon reaching the nesting depth limit. This can lead to memory exhaustion and denial of service.