Skip to main content
VulnerabilityPublished

CVE-2026-116187: rclone · Insecure Direct Object Reference

Affects rcloneSource CVE Database V5

0

Not known to be exploited · CVSS 6.1 Medium : upgrade to 1.75.2 when convenient.

Data as of 26 Oct 2026, 14:18 UTC

CVSS 4.0 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.75.2
CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:H/VI:L/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade rclone to 1.75.2.

Affected software

ProductAffectedFixed in
rclonercloneAffected
  • >=1.68.0 <1.75.2
Fixed in
  • 1.75.2
Gorclonepkg:golang/rcloneOther threatsAffected
  • >=1.68.0 <1.75.2
Fixed in
  • 1.75.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in rclone version 1.75.2 that fixes this authorization bypass vulnerability. Users should upgrade to version 1.75.2 or later to remediate this issue. Since this is a cloud service feature, the vendor manages remediation for cloud-hosted instances; verify with the vendor advisory for cloud service patch status.

Description

Rclone versions from 1.68.0 up to but not including 1.75.2 contain an authorization bypass vulnerability in the serve s3 --auth-proxy feature. This flaw allows authenticated tenants to manipulate multipart uploads belonging to other tenants by referencing their upload IDs. Attackers who know a victim's bucket, object, and upload ID can inject parts, complete, or abort ongoing uploads and access upload and object metadata across tenants. The vulnerability is fixed in version 1.75.2.

References

Community reviews

Loading reviews…