Skip to main content
VulnerabilityPublished

CVE-2026-116245: pgAdmin 4 · Insufficiently Protected Credentials

Affects pgAdmin 4Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.2 High : upgrade to 9.19 soon.

Data as of 30 Oct 2026, 20:38 UTC

CVSS 3.1 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (PostgreSQL)CVSS 3.18.2
CNA (PostgreSQL)CVSS 4.07.1
Patch
Available – fixed in 9.19
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade pgAdmin 4 to 9.19.

Affected software

ProductAffectedFixed in
pgadmin.orgpgAdmin 4Affected
  • <9.19
Fixed in
  • 9.19
GitHubpgAdmin 4pkg:github/pgAdmin 4Other threatsAffected
  • <9.19
Fixed in
  • 9.19

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade pgAdmin 4 to version 9.19 or later, where this vulnerability is fixed. The fix includes the introduction of the SERVER_MODE_ALLOWED_SERVICES setting to restrict allowed services, refusal of the servicefile parameter in server mode, and removal of PGPASSWORD and PGSERVICE environment variables at startup. No additional action is required if the software is updated to the fixed version.

Description

CVE-2026-116245 is a vulnerability in pgAdmin 4 before version 9.19 where insufficient protection of credentials allows unauthorized users in server mode to connect using stored service credentials. The issue arises because libpq uses connection service entries from the operating system account running pgAdmin 4, which can include passwords or references to password files or client certificates. The vulnerability is addressed in pgAdmin 4 version 9.19 by introducing a SERVER_MODE_ALLOWED_SERVICES setting that restricts allowed services, disallows the servicefile parameter, and removes sensitive environment variables at startup.

References

Community reviews

Loading reviews…