Skip to main content
VulnerabilityPublished

CVE-2026-116248: pgAdmin 4 · Missing Authorization

Affects pgAdmin 4Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.8 Medium : upgrade to 9.19 when convenient.

Data as of 30 Oct 2026, 20:18 UTC

CVSS 3.1 base score
6.8Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (PostgreSQL)CVSS 3.16.8
CNA (PostgreSQL)CVSS 4.06.0
Patch
Available – fixed in 9.19
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade pgAdmin 4 to 9.19.

Affected software

ProductAffectedFixed in
pgadmin.orgpgAdmin 4Affected
  • <9.19
Fixed in
  • 9.19
GitHubpgAdmin 4pkg:github/pgAdmin 4Other threatsAffected
  • <9.19
Fixed in
  • 9.19

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade pgAdmin 4 to version 9.19 or later, where this vulnerability is fixed. The fix enforces authorization by refusing non-administrator requests to share servers with an HTTP 403 response, prunes unauthorized shared entries during servers.json import before validation, and warns administrators about previously shared servers created by non-administrators. No additional mitigation is required once the upgrade is applied.

Description

CVE-2026-116248 is a missing authorization vulnerability in pgAdmin 4 server mode prior to version 9.19. It allows non-administrative users to create or import shared servers that appear trusted to other users, potentially tricking them into connecting to attacker-controlled hosts and exposing their database credentials. The vulnerability arises because the server API improperly accepts and stores the 'shared' flag from non-administrators, and the servers.json import only removes unauthorized shared entries after validation. The issue is fixed in pgAdmin 4 version 9.19 by rejecting unauthorized share requests and pruning shared entries from imports before validation.

References

Community reviews

Loading reviews…