Skip to main content
VulnerabilityPublished

CVE-2026-116489: timescale pgvectorscale · Type Confusion

Affects timescale pgvectorscaleSource CVE Database V5

0

Not known to be exploited · CVSS 7.7 High : upgrade to 0.9.1 soon.

Data as of 26 Oct 2026, 17:30 UTC

CVSS 4.0 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.9.1
CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade pgvectorscale and timescale/pgvectorscale to 0.9.1.

Affected software

ProductAffectedFixed in
timescalepgvectorscaleAffected
  • <0.9.1
Fixed in
  • 0.9.1
GitHubtimescale/pgvectorscalepkg:github/timescale/pgvectorscaleOther threatsAffected
  • <0.9.1
Fixed in
  • 0.9.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade timescale pgvectorscale to version 0.9.1 or later, where this type confusion vulnerability is fixed. No other mitigation or workaround is indicated.

Description

CVE-2026-116489 is a type confusion vulnerability in timescale pgvectorscale versions before 0.9.1. It allows low-privileged database users with CREATE privilege on the vectorscale schema to corrupt memory by shadowing pgvector's vector type or operators. Exploitation involves pre-creating shadow objects and querying DiskANN indexes with crafted values, leading to out-of-bounds memory reads and writes. This can result in memory disclosure, server crashes, or privilege escalation. The vulnerability is fixed in version 0.9.1.

References

Community reviews

Loading reviews…