CVE-2026-116541: netty-tcnative · Incorrect Calculation
Affects netty-tcnativeSource CVE Database V5
Not known to be exploited · CVSS 8.2 High : upgrade to 2.0.84.Final soon.
Data as of 26 Oct 2026, 17:30 UTC
- Patch
- Available – fixed in 2.0.84.Final
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 26 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade netty-tcnative and netty-tcnative-boringssl-static and netty/io.netty:netty-tcnative and netty/io.netty:netty-tcnative-boringssl-static to 2.0.84.Final.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| netty-tcnativeio.netty:netty-tcnative | Affected
| Fixed in
|
| netty-tcnative-boringssl-staticio.netty:netty-tcnative-boringssl-static | Affected
| Fixed in
|
Mavennetty/io.netty:netty-tcnativepkg:maven/netty/io.netty:netty-tcnativeOther threats | Affected
| Fixed in
|
Mavennetty/io.netty:netty-tcnative-boringssl-staticpkg:maven/netty/io.netty:netty-tcnative-boringssl-staticOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade netty-tcnative to version 2.0.84.Final or later, where this vulnerability is fixed. No other mitigation is indicated.
Description
CVE-2026-116541 is a denial of service vulnerability in netty-tcnative versions before 2.0.84.Final. The flaw occurs in the tcn_write_to_bytebuffer BIO write callback, which incorrectly calculates bytes consumed. This can be exploited by remote TLS 1.3 peers sending queued post-handshake records such as NewSessionTicket or KeyUpdate, causing truncated flights, connection failures, or JVM process aborts.
References
- github.com/netty/netty-tcnative/security/advisories/GHSA-9xr3-jwv4-r489 (opens in a new tab)
- github.com/netty/netty-tcnative/commit/e31df4a5885b35085fdfa3e2dca7c1f705d4745b (opens in a new tab)
- github.com/netty/netty-tcnative/blob/netty-tcnative-parent-2.0.83.Final/openssl-dynamic/src/main/c/ssl.c (opens in a new tab)
- github.com/netty/netty-tcnative/releases/tag/netty-tcnative-parent-2.0.84.Final (opens in a new tab)
- github.com/netty/netty-tcnative (opens in a new tab)
- vulncheck.com/advisories/netty-tcnative-before-2.0.84-final-denial-of-service-via-bio-write-overcount (opens in a new tab)