CVE-2026-116582: lxsmnsyc seroval · Cross-site Scripting
Affects lxsmnsyc serovalSource CVE Database V5
Not known to be exploited · CVSS 4.7 Medium : upgrade to 1.6.10 or 1.0.0 when convenient.
Data as of 26 Oct 2026, 21:28 UTC
- Patch
- Available – fixed in 1.6.10, 1.0.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 26 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade lxsmnsyc seroval to 1.6.10 or 1.0.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| lxsmnsycseroval | Affected
| Fixed in
|
| lxsmnsycseroval | Affected
| Fixed in
|
AI-suggested
Upgrade to seroval version 1.6.10 or later, where this vulnerability is fixed.
Description
A cross-site scripting (XSS) vulnerability exists in the lxsmnsyc seroval library's JavaScript-output APIs prior to version 1.0.0 and from 1.5.5 up to but not including 1.6.10. The issue arises when regular expressions containing a less-than character are serialized without proper escaping for embedding in HTML script elements. This can allow an attacker to inject malicious scripts if untrusted input is serialized and embedded in a web page. The vulnerability is fixed in version 1.6.10.