Skip to main content
VulnerabilityPublished

CVE-2026-116591: klauspost compress · Integer Overflow or Wraparound

Affects klauspost compressSource CVE Database V5

0

Not known to be exploited · CVSS 8.7 High : upgrade to 1.20.2 soon.

Data as of 26 Oct 2026, 22:15 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.20.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade klauspost compress to 1.20.2.

Affected software

ProductAffectedFixed in
klauspostcompressAffected
  • <1.20.2
Fixed in
  • 1.20.2

AI-suggested

Upgrade to klauspost compress version 1.20.2 or later, where this integer overflow vulnerability is fixed. No other mitigation is required as the fix addresses the root cause. Applications using affected versions prior to 1.20.2 remain vulnerable until updated.

Description

CVE-2026-116591 is a high-severity integer overflow vulnerability in the klauspost compress library prior to version 1.20.2. It affects the zstd DecodeAll and streaming decoder paths, where crafted input can cause a panic due to an integer wraparound in the huff0.ReadTable function. This leads to reuse of stale decode-table state and out-of-range indexing, resulting in application crashes. The issue is fixed in version 1.20.2.

References

Community reviews

Loading reviews…