Skip to main content
VulnerabilityPublished

CVE-2026-116685: modelcontextprotocol python-sdk · Information Exposure

Affects modelcontextprotocol python-sdkSource CVE Database V5

0

Not known to be exploited · CVSS 5.9 Medium : upgrade to 2.2.0 or 1.30.0 when convenient.

Data as of 27 Oct 2026, 19:59 UTC

CVSS 3.1 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.2.0, 1.30.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade python-sdk and modelcontextprotocol-python-sdk to 2.2.0 or 1.30.0.

Affected software

ProductAffectedFixed in
modelcontextprotocolpython-sdkAffected
  • >=2.0.0 <2.2.0
Fixed in
  • 2.2.0
modelcontextprotocolpython-sdkAffected
  • >=1.8.0 <1.30.0
Fixed in
  • 1.30.0
PyPImodelcontextprotocol-python-sdkpkg:pypi/modelcontextprotocol-python-sdkOther threatsAffected
  • >=1.8.0 <1.30.0
  • >=2.0.0 <2.2.0
Fixed in
  • 1.30.0
  • 2.2.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade the Model Context Protocol Python SDK to version 1.30.0 or later, or 2.2.0 or later, where this vulnerability is fixed. No other mitigations are indicated by the vendor advisory.

Description

CVE-2026-116685 is a vulnerability in the Model Context Protocol Python SDK versions from 1.8.0 up to but not including 1.30.0, and from 2.0.0 up to but not including 2.2.0. Certain client components improperly follow HTTP redirects to different origins while forwarding sensitive custom credential headers and request bodies, potentially exposing sensitive information to unauthorized actors. This issue is fixed in versions 1.30.0 and 2.2.0.

References

Community reviews

Loading reviews…