CVE-2026-116870: Octopus Server · Improper Validation of Unsafe Equivalence in Input
Affects Octopus ServerSource CVE Database V5
Not known to be exploited · CVSS 8.7 High · fixed in 2026.3.15816 : patch Octopus Server soon.
Data as of 27 Oct 2026, 10:57 UTC
- Patch
- Available – fixed in 2026.3.15816, 2026.2.13438, 2026.1.11781
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 27 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Octopus Server to 2026.3.15816, 2026.2.13438 or 2026.1.11781.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Octopus DeployOctopus Server | Affected
| Fixed in
|
| Octopus DeployOctopus Server | Affected
| Fixed in
|
| Octopus DeployOctopus Server | Affected
| Fixed in
|
AI-suggested
Apply the official fixes available in Octopus Server versions 2026.1.11781, 2026.2.13438, and 2026.3.15816 or later. Since this is not a cloud service, administrators should upgrade affected instances to these fixed versions to remediate the vulnerability.
Description
CVE-2026-116870 is a high-severity vulnerability in Octopus Deploy Octopus Server where OIDC token issuer validation was inconsistently performed. This flaw could allow a token from a non-legitimate issuer to be accepted as if it belonged to a legitimate trusted service account. Exploitation requires a service account with an OIDC identity configured and some knowledge of that identity. Fixed versions are available.