Skip to main content
VulnerabilityPublished

CVE-2026-116875: SemanticMediaWiki · Cross-site Scripting

Affects SemanticMediaWikiSource CVE Database V5

0

Not known to be exploited · CVSS 5.3 Medium : upgrade to 7.3.1 when convenient.

Data as of 27 Oct 2026, 10:57 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 7.3.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade SemanticMediaWiki and semanticmediawiki/SemanticMediaWiki to 7.3.1.

Affected software

ProductAffectedFixed in
SemanticMediaWikiSemanticMediaWikiAffected
  • >=3.0.0 <7.3.1
Fixed in
  • 7.3.1
GitHubsemanticmediawiki/SemanticMediaWikipkg:github/semanticmediawiki/SemanticMediaWikiOther threatsAffected
  • >=3.0.0 <7.3.1
Fixed in
  • 7.3.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade SemanticMediaWiki to version 7.3.1 or later, where this vulnerability is fixed. No other specific mitigations are indicated by the vendor advisory.

Description

SemanticMediaWiki versions from 3.0.0 up to but not including 7.3.1 contain a reflected cross-site scripting (XSS) vulnerability in the Special:Ask feature. This flaw arises because certain separator parameters are output without proper HTML escaping in various result printers. An unauthenticated attacker can craft malicious links that execute JavaScript in the context of the wiki, potentially stealing session cookies or CSRF tokens. The vulnerability is fixed in version 7.3.1.

References

Community reviews

Loading reviews…