Skip to main content
VulnerabilityPublished

CVE-2026-117561: codefriar sf-mcp · OS Command Injection

Affects codefriar sf-mcpSource CVE Database V5

0

Not known to be exploited · CVSS 8.5 High · patch available : patch codefriar sf-mcp soon.

Data as of 27 Oct 2026, 13:57 UTC

CVSS 4.0 base score
8.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
codefriarsf-mcpAffected
  • <=1.3.2
Fixed in–
npmsf-mcppkg:npm/sf-mcpOther threatsAffected
  • <=1.3.2
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Since sf-mcp is a cloud-hosted service, the vendor manages remediation server-side. Users should verify with the vendor advisory that their service instance has been updated to a fixed version beyond 1.3.2. No additional user action is required if the vendor has applied the patch.

Description

Codefriar sf-mcp versions up to 1.3.2 contain an OS command injection vulnerability. This flaw arises because the escapeValue() function does not properly neutralize shell metacharacters such as backticks and $() substitutions. As a result, crafted Salesforce CLI tool flag values can lead to arbitrary shell command execution with the privileges of the MCP server user. The vulnerability has a high severity score of 8.5 and affects all versions from 0 up to and including 1.3.2. A patch is available, and since this is a cloud service, the vendor manages remediation server-side.

References

Community reviews

Loading reviews…