Skip to main content
VulnerabilityPublished

CVE-2026-117611: Checkmk · Improper Certificate Validation

Affects CheckmkSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.1 High · fixed in 2.5.0p18 : patch Checkmk soon.

Data as of 29 Oct 2026, 10:48 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (Checkmk)CVSS 4.07.1
Patch
Available – fixed in 2.5.0p18, 2.4.0p39, 2.3.0p52
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Checkmk and checkmk/checkmk to 2.5.0p18, 2.4.0p39 or 2.3.0p52.

Affected software

ProductAffectedFixed in
Checkmk GmbHCheckmkAffected
  • >=2.5.0 <2.5.0p18
  • >=2.4.0 <2.4.0p39
  • >=2.3.0 <2.3.0p52
  • =2.2.0
Fixed in
  • 2.5.0p18
  • 2.4.0p39
  • 2.3.0p52
GitHubcheckmk/checkmkpkg:github/checkmk/checkmkOther threatsAffected
  • =2.2.0
  • >=2.3.0 <2.3.0p52
  • >=2.4.0 <2.4.0p39
  • >=2.5.0 <2.5.0p18
Fixed in
  • 2.3.0p52
  • 2.4.0p39
  • 2.5.0p18

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Fixed versions are available: 2.3.0p52, 2.4.0p39, and 2.5.0p18. Users should upgrade affected Checkmk installations to these versions or later to remediate the vulnerability. No additional mitigation steps are indicated by the vendor advisory.

Description

CVE-2026-117611 is a high-severity vulnerability in Checkmk before certain patch levels, caused by improper certificate validation. The affected versions include Checkmk versions 2.2.0, and versions from 2.3.0 up to but not including 2.3.0p52, 2.4.0 up to but not including 2.4.0p39, and 2.5.0 up to but not including 2.5.0p18. The issue arises because the Certificate Authority stores bundled with the software include a root CA that trusts eMudhra (emSign) intermediate certificates whose private keys are publicly known. This improper validation could undermine the trust model of TLS connections. Fixes are available in versions 2.3.0p52, 2.4.0p39, and 2.5.0p18.

References

Community reviews

Loading reviews…