CVE-2026-117680: lud jsv · Unchecked Error Condition
Affects lud jsvSource CVE Database V5
Not known to be exploited · CVSS 2.1 Low : upgrade to 0.26.2 when convenient.
Data as of 1 Nov 2026, 13:58 UTC
Thin evidence
One scorer or none| CNA (EEF) | CVSS 4.0 | 2.1 |
|---|
- Patch
- Available – fixed in 0.26.2, defdb8a68ac7f218aa5dfe85190d484017cb8817
CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 1 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Upgrade jsv to 0.26.2; jsv to defdb8a68ac7f218aa5dfe85190d484017cb8817.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| ludjsv | Affected
| Fixed in
|
| jsvlud/jsv | Affected
| Fixed in
|
Hexjsvpkg:hex/jsvOther threats | Affected
| Fixed in
|
CPE configurations (1)
cpe:2.3:a:lud:jsv:*:*:*:*:*:*:*:*
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade lud jsv to version 0.26.2 or later, where this issue is fixed. No other mitigation is required as the vulnerability is addressed by the official patch.
Description
CVE-2026-117680 is a low-severity vulnerability in the lud jsv library affecting versions from 0.1.0 up to but not including 0.26.2. It involves an improper check for unusual or exceptional conditions in schema validation related to regex backtracking limits. An unauthenticated remote attacker can bypass schema validation by exploiting regex patterns that cause heavy backtracking, leading to incorrect acceptance of invalid data. The issue is fixed in version 0.26.2.
References
- github.com/lud/jsv/security/advisories/GHSA-cvmg-hgv6-jqcp (opens in a new tab)
- cna.erlef.org/cves/CVE-2026-117680.html (opens in a new tab)
- osv.dev/vulnerability/EEF-CVE-2026-117680 (opens in a new tab)
- github.com/lud/jsv/commit/302a5d0803468f81a1cf08e3b67d8b14cee759ca (opens in a new tab)
- github.com/lud/jsv/commit/defdb8a68ac7f218aa5dfe85190d484017cb8817 (opens in a new tab)