Skip to main content
VulnerabilityPublished

CVE-2026-118038: Progress Software Telerik Document Processing Libraries · Path Traversal

Affects Progress Software Telerik Document Processing LibrariesSource CVE Database V5

0

Not known to be exploited · CVSS 7.1 High : upgrade to 2026.3.1027 soon.

Data as of 28 Oct 2026, 12:57 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2026.3.1027
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Telerik Document Processing Libraries and telerik.documentprocessinglibraries to 2026.3.1027.

Affected software

ProductAffectedFixed in
Progress SoftwareTelerik Document Processing LibrariesAffected
  • >=2026.1.210 <2026.3.1027
Fixed in
  • 2026.3.1027
NuGettelerik.documentprocessinglibrariespkg:nuget/telerik.documentprocessinglibrariesOther threatsAffected
  • >=2026.1.210 <2026.3.1027
Fixed in
  • 2026.3.1027

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Telerik Document Processing Libraries to version 2026.3.1027 or later, where this path traversal vulnerability is fixed. No other mitigation or workaround is indicated by the vendor advisory.

Description

CVE-2026-118038 is a path traversal vulnerability in Progress Software's Telerik Document Processing Libraries prior to version 2026.3.1027. It affects the Convert and Merge AI agent tools, allowing an authenticated low-privilege attacker who can supply tool arguments to read and overwrite files outside the configured output directory using relative file paths. The vulnerability is fixed in version 2026.3.1027.

References

Community reviews

Loading reviews…