CVE-2026-118057: Shield Security (WordPress plugin) · Cross-site Scripting
Affects Shield Security (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 7.2 High · fixed in 18.5.8 : patch Shield Security (WordPress plugin) soon.
Data as of 31 Oct 2026, 08:10 UTC
Thin evidence
One scorer or none| CNA (Wordfence) | CVSS 3.1 | 7.2 |
|---|
- Patch
- Available – fixed in 18.5.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 31 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| paultgoodchildShield Security – Smart Bot Blocking, Brute-Force Login Protection & File Scanning | Affected
| Fixed in– |
AI-suggested
No explicit patch links or vendor advisories confirming a fix are provided. Since the vulnerability affects all versions up to and including 22.3.2, users should upgrade to a version later than 22.3.2 once available. Until then, consider disabling or restricting access to the affected plugin features that render the vulnerable 'path' column. Monitor the vendor's official channels for an official fix and apply it promptly when released.
Description
The Shield Security plugin for WordPress, up to version 22.3.2, contains a stored cross-site scripting (XSS) vulnerability via the 'REQUEST_URI' parameter. This vulnerability arises from insufficient input sanitization and output escaping in a hidden 'path' column rendered by DataTables using innerHTML, allowing unauthenticated attackers to inject malicious scripts that execute when users access the affected pages. A partial fix in version 18.5.8 addressed escaping in a visible column but left the hidden 'path' field vulnerable through version 22.2.6.
References
- wordfence.com/threat-intel/vulnerabilities/id/3781bf74-541a-4dfb-a058-1a9ea6aa970e?source=cve (opens in a new tab)
- plugins.trac.wordpress.org/browser/wp-simple-firewall/tags/22.2.6/src/Logging/Processors/RequestMetaProcessor.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/wp-simple-firewall/tags/22.2.6/src/Tables/DataTables/LoadData/Traffic/BuildTrafficTableData.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/wp-simple-firewall/tags/22.2.6/src/Tables/DataTables/Build/ForTraffic.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/wp-simple-firewall/tags/22.2.6/src/Logging/Processors/RequestMetaProcessor.php (opens in a new tab)
- plugins.trac.wordpress.org/changeset?reponame=&new=3769612%40wp-simple-firewall%2Ftags%2F22.3.4&old=3768418%40wp-simple-firewall%2Ftags%2F22.3.2 (opens in a new tab)