Skip to main content
VulnerabilityPublished

CVE-2026-118264: labstack echo · HTTP Request/Response Smuggling

Affects labstack echoSource CVE Database V5

0

Not known to be exploited · CVSS 9.1 Critical : upgrade to 5.4.1 or 4.16.1 as a priority.

Data as of 28 Oct 2026, 19:27 UTC

CVSS 4.0 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.4.1, 4.16.1
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade labstack echo to 5.4.1 or 4.16.1.

Affected software

ProductAffectedFixed in
labstackechoAffected
  • >=5.0.0 <5.4.1
Fixed in
  • 5.4.1
labstackechoAffected
  • >=4.0.0 <4.16.1
Fixed in
  • 4.16.1

AI-suggested

Upgrade Echo to version 4.16.1 or later, or 5.4.1 or later, where this vulnerability is fixed.

Description

A critical HTTP request/response smuggling vulnerability (CVE-2026-118264) affects the Echo Go web framework versions from 4.0.0 up to but not including 4.16.1 and from 5.0.0 up to but not including 5.4.1. The flaw arises in Echo's Proxy middleware, which improperly handles client WebSocket upgrade requests by selecting a raw tunnel before verifying upstream acceptance. If the upstream rejects the upgrade with a keep-alive response, subsequent HTTP requests bypass Echo's routing and middleware, potentially allowing attackers to circumvent authentication or authorization controls enforced by Echo routes. This vulnerability is fixed in versions 4.16.1 and 5.4.1.

References

Community reviews

Loading reviews…