Skip to main content
VulnerabilityPublished

CVE-2026-11832: BIAFRA Dancer2::Plugin::Auth::OAuth · PRNG

Affects BIAFRA Dancer2::Plugin::Auth::OAuthSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.1 Critical : upgrade to 0.22 as a priority.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.22
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Dancer2::Plugin::Auth::OAuth and Dancer2-Plugin-Auth-OAuth to 0.22.

Affected software

ProductAffectedFixed in
BIAFRADancer2::Plugin::Auth::OAuthAffected
  • <0.22
Fixed in
  • 0.22
GitHubDancer2-Plugin-Auth-OAuthpkg:github/Dancer2-Plugin-Auth-OAuthOther threatsAffected
  • <0.22
Fixed in
  • 0.22

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, users should consider implementing custom nonce generation using a cryptographically secure random number generator or upgrading to version 0.22 or later once available.

Description

Dancer2::Plugin::Auth::OAuth versions before 0.22 for Perl use a predictable nonce generated by hashing the epoch time with MD5, which is a cryptographically weak pseudo-random number generator. This vulnerability (CVE-2026-11832) can lead to compromised confidentiality and integrity of authentication tokens. The CVSS score is 9.1, indicating a critical severity level.

References

Community reviews

Loading reviews…