CVE-2026-118654: labstack echo · Path Traversal
Affects labstack echoSource CVE Database V5
Mentioned vulnerabilities
Not known to be exploited · CVSS 5.9 Medium : upgrade to 5.4.0 or 4.16.0 when convenient.
Data as of 28 Oct 2026, 20:29 UTC
- Patch
- Available – fixed in 5.4.0, 4.16.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade echo and github.com/labstack/echo to 5.4.0 or 4.16.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| labstackecho | Affected
| Fixed in
|
| labstackecho | Affected
| Fixed in
|
Gogithub.com/labstack/echopkg:golang/github.com/labstack/echoOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Echo to version 4.16.0 or later in the 4.x series, or to version 5.4.0 or later in the 5.x series, where this vulnerability has been fixed. No other mitigation or temporary workaround is indicated by the vendor advisory.
Description
CVE-2026-118654 is a path traversal vulnerability in the Echo Go web framework's static file handlers prior to versions 4.16.0 and 5.4.0. The flaw allows an unauthenticated attacker to bypass route-level middleware protections by exploiting how dot segments are normalized after route matching, enabling unauthorized reading of protected files accessible via static filesystem mounts. This issue is a regression from an incomplete fix of a previous vulnerability (CVE-2026-55677) and is resolved in Echo versions 4.16.0 and 5.4.0.
References
- github.com/labstack/echo/security/advisories/GHSA-3pmx-cf9f-34xr (opens in a new tab)
- github.com/labstack/echo/commit/b838391e2eade87ae7e5a09d7bb5087bec271ec1 (opens in a new tab)
- github.com/labstack/echo/commit/fc410094b2f3415cf2bf5204082137b205bfd5af (opens in a new tab)
- github.com/labstack/echo/releases/tag/v4.16.0 (opens in a new tab)
- github.com/labstack/echo/releases/tag/v5.4.0 (opens in a new tab)