Skip to main content
VulnerabilityPublished

CVE-2026-118687: coder · Confused Deputy

Affects coderSource CVE Database V5

0

Not known to be exploited · CVSS 8.3 High : upgrade to 2.37.4 soon.

Data as of 28 Oct 2026, 19:27 UTC

CVSS 4.0 base score
8.3High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.37.4, 2.36.7, 2.35.9 +2
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
codercoderAffected
  • >=2.37.0 <2.37.4
Fixed in
  • 2.37.4
codercoderAffected
  • >=2.36.0 <2.36.7
Fixed in
  • 2.36.7
codercoderAffected
  • >=2.35.0 <2.35.9
Fixed in
  • 2.35.9
codercoderAffected
  • >=2.30.0 <2.34.12
Fixed in
  • 2.34.12
codercoderAffected
  • <2.29.21
Fixed in
  • 2.29.21
Gocoderpkg:golang/coderOther threatsAffected
  • >=2.37.0 <2.37.4
  • >=2.36.0 <2.36.7
  • >=2.35.0 <2.35.9
  • >=2.30.0 <2.34.12
  • <2.29.21
Fixed in
  • 2.37.4
  • 2.36.7
  • 2.35.9
  • 2.34.12
  • 2.29.21

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Fixed versions are available: 2.29.21, 2.34.12, 2.35.9, 2.36.7, and 2.37.4. Users should upgrade to these versions or later to remediate the vulnerability. There is no indication that other mitigations or workarounds are provided or necessary.

Description

Coder versions before 2.29.21, 2.30.0 before 2.34.12, 2.35.0 before 2.35.9, 2.36.0 before 2.36.7, and 2.37.0 before 2.37.4 have a vulnerability where the audience claim of Google Cloud Engine instance-identity JWTs is not validated at a specific API endpoint. This allows attackers with a valid identity token for another relying party to replay it and obtain a workspace agent's session token, which remains valid until the next build.

References

Community reviews

Loading reviews…