Skip to main content
VulnerabilityPublished

CVE-2026-118786: NXP MCUXpresso SDK · Improper Input Validation

Affects NXP MCUXpresso SDKSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.8 Medium : upgrade to 26.12.00-pvw1 or 26.06.01-lts when convenient.

Data as of 6 Nov 2026, 22:51 UTC

CVSS 3.1 base score
6.8Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (ENISA)CVSS 3.16.8
Patch
Available – fixed in 26.12.00-pvw1, 26.06.01-lts
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade NXP MCUXpresso SDK to 26.12.00-pvw1 or 26.06.01-lts.

Affected software

ProductAffectedFixed in
NXPMCUXpresso SDKAffected
  • <26.12.00-pvw1
Fixed in
  • 26.12.00-pvw1
NXPMCUXpresso SDKAffected
  • <26.06.01-lts
Fixed in
  • 26.06.01-lts

AI-suggested

The vulnerability is fixed in MCUXpresso SDK versions 26.06.01-lts and 26.12.00-pvw1. Users should upgrade to these or later versions to remediate the issue. No additional mitigation actions are indicated.

Description

CVE-2026-118786 is an improper input validation vulnerability in the non-secure-callable veneer functions of the NXP MCUXpresso SDK rpmsg-lite multicore example. This flaw affects versions up to 26.06.00-lts and 26.09.00, allowing a non-secure caller to supply unvalidated pointers and size values. Exploitation could lead to disclosure of secure-world memory or denial of service. The issue is fixed in versions 26.06.01-lts and 26.12.00-pvw1.

References

Community reviews

Loading reviews…